core/apr/PKGBUILD

38 lines
777 B
Bash

#
# Core Packages for Chakra, part of chakra-project.org
#
# maintainer abveritas[at]chakra-project[dot]org>
pkgname=apr
pkgver=1.4.6
pkgrel=1
pkgdesc="The Apache Portable Runtime"
arch=('x86_64')
url="http://apr.apache.org/"
depends=('util-linux')
options=('!libtool')
license=('APACHE')
source=("http://www.apache.org/dist/apr/apr-${pkgver}.tar.bz2")
md5sums=('ffee70a111fd07372982b0550bbb14b7')
build() {
cd "${srcdir}/apr-${pkgver}"
./configure --prefix=/usr --includedir=/usr/include/apr-1 \
--with-installbuilddir=/usr/share/apr-1/build \
--enable-nonportable-atomics \
--with-devrandom=/dev/urandom
make
}
check() {
cd "${srcdir}/apr-${pkgver}"
make -j1 check
}
package() {
cd "${srcdir}/apr-${pkgver}"
make DESTDIR="${pkgdir}" install
}