mirror of
https://gitdl.cn/https://github.com/chakralinux/core.git
synced 2025-01-23 18:14:54 +08:00
37 lines
714 B
Bash
37 lines
714 B
Bash
#
|
|
# Core Packages for Chakra, part of chakra-project.org
|
|
#
|
|
# maintainer abveritas@chakra-project.org
|
|
|
|
pkgname=automake
|
|
pkgver=1.11.3
|
|
pkgrel=1
|
|
pkgdesc="A GNU tool for automatically creating Makefiles"
|
|
arch=('any')
|
|
license=('GPL')
|
|
url="http://www.gnu.org/software/automake"
|
|
groups=('base-devel')
|
|
depends=('perl' 'bash')
|
|
makedepends=('autoconf')
|
|
install=automake.install
|
|
source=(ftp://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz)
|
|
md5sums=('93ecb319f0365cb801990b00f658d026')
|
|
|
|
build() {
|
|
cd ${srcdir}/${pkgname}-${pkgver}
|
|
./configure --prefix=/usr
|
|
make
|
|
}
|
|
|
|
check()
|
|
{
|
|
cd ${srcdir}/${pkgname}-${pkgver}
|
|
make check
|
|
}
|
|
|
|
package() {
|
|
cd ${srcdir}/${pkgname}-${pkgver}
|
|
make DESTDIR=${pkgdir} install
|
|
}
|
|
|