mirror of
https://gitdl.cn/https://github.com/chakralinux/core.git
synced 2025-02-03 03:17:14 +08:00
45 lines
1003 B
Bash
45 lines
1003 B
Bash
#
|
|
# Core Packages for Chakra, part of chakra-project.org
|
|
#
|
|
# maintainer: abveritas@chakra-project.org
|
|
|
|
pkgname=dnsutils
|
|
# _pkver when P version used.
|
|
pkgver=9.9.2.1
|
|
_pkgver=9.9.2-P1
|
|
pkgrel=1
|
|
pkgdesc="Various DNS utilities - dig host nslookup nsupdate"
|
|
arch=('x86_64')
|
|
url="https://www.isc.org/software/bind"
|
|
license=('custom:ISC')
|
|
depends=('openssl')
|
|
options=('makeflags')
|
|
source=("http://ftp.isc.org/isc/bind9/${_pkgver}/bind-${_pkgver}.tar.gz"
|
|
'tools-only.patch')
|
|
md5sums=('44b9d1feb11de09811160775f94c2554'
|
|
'a7b414849b4fb2137e33f348c3cdd458')
|
|
|
|
build() {
|
|
cd "${srcdir}/bind-${_pkgver}"
|
|
|
|
patch -p1 -i "${srcdir}/tools-only.patch"
|
|
export STD_CDEFINES='-DDIG_SIGCHASE'
|
|
|
|
./configure \
|
|
--prefix=/usr \
|
|
--sysconfdir=/etc \
|
|
--localstatedir=/var \
|
|
--disable-static \
|
|
--disable-linux-caps \
|
|
--with-openssl
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd "${srcdir}/bind-${_pkgver}"
|
|
|
|
install -Dm644 COPYRIGHT "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
|
|
cd bin; make DESTDIR="${pkgdir}" install
|
|
}
|