mirror of
https://gitdl.cn/https://github.com/chakralinux/core.git
synced 2025-01-23 18:14:54 +08:00
31 lines
700 B
Bash
31 lines
700 B
Bash
#
|
|
# Chakra Packages for Chakra, part of chakra-project.org
|
|
#
|
|
# maintainer: Manuel Tortosa <manutortosa[at]chakra-project[dot]org>
|
|
|
|
pkgname=gmp
|
|
pkgver=5.0.5
|
|
pkgrel=1
|
|
pkgdesc="A free library for arbitrary precision arithmetic"
|
|
arch=('x86_64')
|
|
url="http://gmplib.org/"
|
|
depends=('gcc-libs' 'sh')
|
|
license=('LGPL3')
|
|
options=('!libtool' 'log')
|
|
install=gmp.install
|
|
source=(ftp://ftp.gnu.org/gnu/gmp/gmp-${pkgver}.tar.xz)
|
|
md5sums=('8aef50959acec2a1ad41d144ffe0f3b5')
|
|
|
|
build() {
|
|
cd "${srcdir}/${pkgname}-${pkgver}"
|
|
./configure --build=${CHOST} \
|
|
--prefix=/usr --infodir=/usr/share/info \
|
|
--enable-cxx
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd "${srcdir}/${pkgname}-${pkgver}"
|
|
make DESTDIR="${pkgdir}" install
|
|
}
|