mirror of
https://gitdl.cn/https://github.com/chakralinux/core.git
synced 2025-01-23 18:14:54 +08:00
31 lines
625 B
Bash
31 lines
625 B
Bash
#
|
|
# Core Packages for Chakra, part of chakra-project.org
|
|
#
|
|
# maintainer abveritas@chakra-project.org
|
|
|
|
pkgname=libyaml
|
|
pkgver=0.1.4
|
|
pkgrel=2
|
|
pkgdesc="YAML 1.1 library"
|
|
arch=('x86_64')
|
|
url="http://pyyaml.org/wiki/LibYAML"
|
|
license=('MIT')
|
|
conflict=('yaml')
|
|
provides=('yaml')
|
|
replaces=('yaml')
|
|
source=("http://pyyaml.org/download/libyaml/yaml-$pkgver.tar.gz")
|
|
md5sums=('36c852831d02cf90508c29852361d01b')
|
|
|
|
build() {
|
|
cd "$srcdir/yaml-$pkgver"
|
|
|
|
./configure --prefix=/usr
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd "$srcdir/yaml-$pkgver"
|
|
|
|
make DESTDIR="$pkgdir" install
|
|
install -m644 -D LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
|
|
} |