mirror of
https://gitdl.cn/https://github.com/chakralinux/core.git
synced 2025-01-23 18:14:54 +08:00
69 lines
2.1 KiB
Bash
69 lines
2.1 KiB
Bash
#
|
|
# Core Packages for Chakra, part of chakra-project.org
|
|
#
|
|
|
|
pkgname=openmpi
|
|
pkgver=1.5.5
|
|
pkgrel=1
|
|
pkgdesc="High performance message passing library (MPI)"
|
|
arch=('i686' 'x86_64')
|
|
url="http://www.open-mpi.org"
|
|
license=('custom')
|
|
depends=('gcc' 'gcc-fortran' 'openssh' 'valgrind' 'libtool' 'hwloc')
|
|
makedepends=('inetutils')
|
|
options=(!libtool)
|
|
source=(http://www.open-mpi.org/software/ompi/v1.5/downloads/${pkgname}-${pkgver}.tar.bz2
|
|
openmpi-1.5.4-fix-fakeroot-execution.patch)
|
|
sha1sums=('206e555f6d376443f2342f721d944e67dd1a04ef'
|
|
'3161fce9870e02211dadbc0993b7805e2e811440')
|
|
|
|
build() {
|
|
cd "${srcdir}/${pkgname}-${pkgver}"
|
|
|
|
# Fix fakeroot
|
|
patch -p1 -i $srcdir/openmpi-1.5.4-fix-fakeroot-execution.patch
|
|
|
|
./configure --prefix=/usr \
|
|
--sysconfdir=/etc/${pkgname} \
|
|
--mandir=/usr/share/man \
|
|
--enable-mpi-f90 \
|
|
--libdir=/usr/lib/${pkgname} \
|
|
--with-threads=posix \
|
|
--enable-smp-locks \
|
|
--with-valgrind \
|
|
--enable-memchecker \
|
|
--enable-debug \
|
|
--enable-pretty-print-stacktrace \
|
|
--without-slurm \
|
|
--with-hwloc=/usr \
|
|
--with-libltdl=/usr \
|
|
FC=/usr/bin/gfortran \
|
|
LDFLAGS="$LDFLAGS -Wl,-z,noexecstack"
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd "${srcdir}/${pkgname}-${pkgver}"
|
|
make DESTDIR="${pkgdir}" install
|
|
|
|
install -d -m 755 "${pkgdir}"/usr/lib/pkgconfig
|
|
for i in ompi-c.pc ompi-cxx.pc ompi-f77.pc ompi-f90.pc ompi.pc; do
|
|
ln -sf /usr/lib/openmpi/pkgconfig/$i "${pkgdir}"/usr/lib/pkgconfig/
|
|
done
|
|
|
|
# Openmpi's otfinfo conflicts with the one from texlive
|
|
mv "${pkgdir}"/usr/bin/otfinfo{,mpi}
|
|
|
|
# Openmpi's otfdump conflicts with the one from libotf
|
|
mv "${pkgdir}"/usr/bin/otfdump{,ompi}
|
|
|
|
# Remove dangling symlink
|
|
rm "${pkgdir}"/usr/share/man/man1/orteCC.1
|
|
|
|
install -d -m 755 "${pkgdir}"/etc/ld.so.conf.d
|
|
echo "/usr/lib/${pkgname}" > "${pkgdir}"/etc/ld.so.conf.d/${pkgname}.conf
|
|
|
|
install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
|
|
}
|