mirror of
https://gitdl.cn/https://github.com/chakralinux/core.git
synced 2025-02-03 02:37:14 +08:00
31 lines
635 B
Bash
31 lines
635 B
Bash
#
|
|
# Core Packages for Chakra, part of chakra-project.org
|
|
#
|
|
# maintainer abveritas@chakra-project.org
|
|
|
|
pkgname=popt
|
|
pkgver=1.16
|
|
pkgrel=4
|
|
pkgdesc="A commandline option parser"
|
|
arch=('x86_64')
|
|
url="http://rpm5.org"
|
|
license=('custom')
|
|
depends=('glibc')
|
|
options=('!libtool')
|
|
source=("http://rpm5.org/files/$pkgname/$pkgname-$pkgver.tar.gz")
|
|
md5sums=('3743beefa3dd6247a73f8f7a32c14c33')
|
|
|
|
build() {
|
|
cd "${srcdir}/${pkgname}-${pkgver}"
|
|
|
|
./configure --prefix=/usr
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd "${srcdir}/${pkgname}-${pkgver}"
|
|
|
|
make DESTDIR="${pkgdir}" install
|
|
install -Dm644 COPYING "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
|
|
}
|