mirror of
https://gitdl.cn/https://github.com/chakralinux/core.git
synced 2025-01-23 18:14:54 +08:00
134 lines
3.9 KiB
Bash
134 lines
3.9 KiB
Bash
#
|
|
# Chakra Packages for Chakra, part of chakra-project.org
|
|
#
|
|
# maintainer abveritas[at]chakra-project[dog]org>
|
|
# maintainer Manuel Tortosa <manutortosa[at]chakra-project[dot]org>
|
|
|
|
pkgname=shadow
|
|
pkgver=4.1.5.1
|
|
pkgrel=1
|
|
pkgdesc="Password and account management tool suite with support for shadow files and PAM"
|
|
arch=('x86_64')
|
|
url='http://pkg-shadow.alioth.debian.org/'
|
|
license=('BSD')
|
|
groups=('base')
|
|
depends=('bash' 'pam' 'acl')
|
|
backup=(etc/login.defs
|
|
etc/pam.d/{chage,passwd,shadow,useradd,usermod,userdel}
|
|
etc/pam.d/{chpasswd,newusers,groupadd,groupdel,groupmod}
|
|
etc/pam.d/{chgpasswd,groupmems}
|
|
etc/default/useradd)
|
|
options=('!libtool')
|
|
install='shadow.install'
|
|
source=("http://pkg-shadow.alioth.debian.org/releases/$pkgname-$pkgver.tar.bz2"{,.sig}
|
|
LICENSE
|
|
adduser
|
|
chgpasswd
|
|
chpasswd
|
|
defaults.pam
|
|
login.defs
|
|
newusers
|
|
passwd
|
|
shadow.cron.daily
|
|
useradd.defaults
|
|
xstrdup.patch
|
|
shadow-strncpy-usage.patch)
|
|
sha1sums=('81f38720b953ef9c2c100c43d02dfe19cafd6c30'
|
|
'126570e2939bf3b57f28df5197ab9309747a6b5c'
|
|
'7ab316761036787c0cfcb53b7a6e82da7c373123'
|
|
'cdb0ec4dc094a091c1053d74b4b6cb89327362dc'
|
|
'4ad0e059406a305c8640ed30d93c2a1f62c2f4ad'
|
|
'87186f6e5e00d195cafba5e38400418481dce3af'
|
|
'0e56fed7fc93572c6bf0d8f3b099166558bb46f1'
|
|
'e5cab2118ecb1e61874cde842d7d04d1003f35cb'
|
|
'12427b1ca92a9b85ca8202239f0d9f50198b818f'
|
|
'49cb1b18af9d2ae7cc4a2441f1a6951d313f7c60'
|
|
'5d83ba7e11c765c951867cbe00b0ae7ff57148fa'
|
|
'80e3d2ee8c990c2f7fbd0dcf406a9e41cbe66fe2'
|
|
'6010fffeed1fc6673ad9875492e1193b1a847b53'
|
|
'3bc0e0968ddec0e58b1e2de88d9d0065c93d60c9')
|
|
|
|
build() {
|
|
cd "$pkgname-$pkgver"
|
|
|
|
# avoid transitive linking issues with binutils 2.22
|
|
sed -i '/^user\(mod\|add\)_LDADD/s|$| -lattr|' src/Makefile.am
|
|
|
|
# link to glibc's crypt(3)
|
|
LDFLAGS+=" -lcrypt"
|
|
|
|
# need to offer these upstream
|
|
patch -p1 <"$srcdir/xstrdup.patch"
|
|
patch -p1 <"$srcdir/shadow-strncpy-usage.patch"
|
|
|
|
# supress etc/pam.d/*, we provide our own
|
|
sed -i '/^SUBDIRS/s/pam.d//' etc/Makefile.in
|
|
|
|
./configure \
|
|
--prefix=/usr \
|
|
--libdir=/lib \
|
|
--mandir=/usr/share/man \
|
|
--sysconfdir=/etc \
|
|
--with-libpam \
|
|
--without-selinux
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd "$pkgname-$pkgver"
|
|
|
|
make DESTDIR="$pkgdir" install
|
|
|
|
# license
|
|
install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/shadow/LICENSE"
|
|
|
|
# interactive useradd
|
|
install -Dm755 "$srcdir/adduser" "$pkgdir/usr/sbin/adduser"
|
|
|
|
# useradd defaults
|
|
install -Dm644 "$srcdir/useradd.defaults" "$pkgdir/etc/default/useradd"
|
|
|
|
# cron job
|
|
install -Dm744 "$srcdir/shadow.cron.daily" "$pkgdir/etc/cron.daily/shadow"
|
|
|
|
# login.defs
|
|
install -Dm644 "$srcdir/login.defs" "$pkgdir/etc/login.defs"
|
|
|
|
# PAM config - custom
|
|
install -dm755 "$pkgdir/etc/pam.d"
|
|
install -t "$pkgdir/etc/pam.d" -m644 "$srcdir"/{passwd,chgpasswd,chpasswd,newusers}
|
|
|
|
# PAM config - from tarball
|
|
install -Dm644 etc/pam.d/groupmems "$pkgdir/etc/pam.d/groupmems"
|
|
|
|
# we use the 'useradd' PAM file for other similar utilities
|
|
for file in chage groupadd groupdel groupmod shadow \
|
|
useradd usermod userdel; do
|
|
install -Dm644 "$srcdir/defaults.pam" "$pkgdir/etc/pam.d/$file"
|
|
done
|
|
|
|
# Remove utilities provided by util-linux
|
|
rm \
|
|
"$pkgdir"/usr/bin/{chsh,chfn,sg} \
|
|
"$pkgdir"/bin/{login,su} \
|
|
"$pkgdir"/usr/sbin/{vipw,vigr}
|
|
|
|
# but we keep newgrp, as sg is really an alias to it
|
|
mv "$pkgdir"/usr/bin/{newgrp,sg}
|
|
|
|
# ...and their many man pages
|
|
find "$pkgdir"/usr/share/man \
|
|
'(' -name 'chsh.1' -o \
|
|
-name 'chfn.1' -o \
|
|
-name 'su.1' -o \
|
|
-name 'login.1' -o \
|
|
-name 'vipw.8' -o \
|
|
-name 'vigr.8' -o \
|
|
-name 'newgrp.1' ')' \
|
|
-delete
|
|
rmdir \
|
|
"$pkgdir"/usr/share/man/{fi,id,zh_TW}/man1 \
|
|
"$pkgdir"/usr/share/man/{fi,ko/man8}
|
|
}
|