mirror of
https://gitdl.cn/https://github.com/chakralinux/core.git
synced 2025-02-03 02:47:13 +08:00
84 lines
3.0 KiB
Bash
84 lines
3.0 KiB
Bash
#
|
|
# Core Packages for Chakra, part of chakra-project.org
|
|
#
|
|
# maintainer abveritas@chakra-project.org
|
|
|
|
pkgname=subversion
|
|
pkgver=1.7.8
|
|
pkgrel=1
|
|
pkgdesc="A Modern Concurrent Version Control System"
|
|
arch=('x86_64')
|
|
license=('apache' 'bsd')
|
|
depends=('neon' 'apr-util' 'sqlite3' 'file')
|
|
optdepends=('kdeutils-kwallet' 'bash-completion: for svn bash completion')
|
|
makedepends=('krb5' 'apache' 'python2' 'perl' 'swig' 'ruby' 'java-runtime'
|
|
'autoconf' 'db' 'e2fsprogs' 'kdelibs')
|
|
#backup=('etc/xinetd.d/svn' 'etc/conf.d/svnserve')
|
|
url="http://subversion.apache.org/"
|
|
provides=('svn')
|
|
options=('!makeflags' '!libtool')
|
|
source=(http://apache.mirror.rafal.ca/subversion/$pkgname-$pkgver.tar.bz2{,.asc}
|
|
svn svnserve.conf
|
|
svnserve.tmpfiles
|
|
svnserve.service
|
|
subversion.rpath.fix.patch)
|
|
md5sums=('454b9f398415c3504435bf8c3f6ed127'
|
|
'8fc10351ec75a103b0c0c69d8ed786b7'
|
|
'a0db6dd43af33952739b6ec089852630'
|
|
'c459e299192552f61578f3438abf0664'
|
|
'bb2857eceafcfac35dde39dcffad2314'
|
|
'e8020c7a1d1a0c47091b5fdd034f81c5'
|
|
'6b4340ba9d8845cd8497e013ae01be3f')
|
|
|
|
build() {
|
|
cd "${srcdir}/${pkgname}-${pkgver}"
|
|
|
|
export PYTHON=/usr/bin/python2
|
|
|
|
patch -p0 -i ../subversion.rpath.fix.patch
|
|
sed -i 's|/usr/bin/env python|/usr/bin/env python2|' tools/hook-scripts/{,mailer/{,tests/}}*.py
|
|
|
|
# configure
|
|
autoreconf
|
|
./configure --prefix=/usr --with-apr=/usr --with-apr-util=/usr \
|
|
--with-zlib=/usr --with-neon=/usr --with-apxs \
|
|
--with-sqlite=/usr \
|
|
--enable-javahl --without-gnome-keyring --with-kwallet
|
|
|
|
make external-all
|
|
make LT_LDFLAGS="-L$Fdestdir/usr/lib" local-all
|
|
make swig_pydir=/usr/lib/python2.7/site-packages/libsvn \
|
|
swig_pydir_extra=/usr/lib/python2.7/site-packages/svn swig-py swig-pl javahl # swig-rb
|
|
}
|
|
|
|
package() {
|
|
cd "${srcdir}/${pkgname}-${pkgver}"
|
|
|
|
export LD_LIBRARY_PATH="${pkgdir}"/usr/lib:${LD_LIBRARY_PATH}
|
|
make DESTDIR="${pkgdir}" INSTALLDIRS=vendor \
|
|
swig_pydir=/usr/lib/python2.7/site-packages/libsvn \
|
|
swig_pydir_extra=/usr/lib/python2.7/site-packages/svn \
|
|
install install-swig-py install-swig-pl install-javahl # install-swig-rb
|
|
|
|
install -d "${pkgdir}"/usr/share/subversion
|
|
cp -a tools/hook-scripts "${pkgdir}"/usr/share/subversion/
|
|
rm "${pkgdir}"/usr/share/subversion/hook-scripts/*.in
|
|
|
|
rm "${pkgdir}"/usr/lib/perl5/vendor_perl/auto/SVN/_Core/.packlist
|
|
rm -r "${pkgdir}"/usr/lib/perl5/core_perl
|
|
|
|
## svnserve
|
|
install -D -m 644 "${srcdir}"/svnserve.conf "${pkgdir}"/etc/conf.d/svnserve
|
|
|
|
# systemd
|
|
install -D -m 644 "${srcdir}"/svnserve.service "${pkgdir}"/usr/lib/systemd/system/svnserve.service
|
|
install -D -m 644 "${srcdir}"/svnserve.tmpfiles "${pkgdir}"/usr/lib/tmpfiles.d/svnserve.conf
|
|
|
|
# bash completion
|
|
install -Dm 644 tools/client-side/bash_completion \
|
|
"${pkgdir}"/usr/share/bash-completion/completions/subversion
|
|
for i in svn svnadmin svndumpfilter svnlook svnsync svnversion; do
|
|
ln -sf subversion "${pkgdir}"/usr/share/bash-completion/completions/${i}
|
|
done
|
|
}
|