mirror of
https://gitdl.cn/https://github.com/chakralinux/core.git
synced 2025-02-03 03:17:14 +08:00
43 lines
1.4 KiB
Bash
43 lines
1.4 KiB
Bash
#
|
|
# Chakra Packages for Chakra, part of chakra-project.org
|
|
#
|
|
# maintainer abveritas@chakra-project.org
|
|
|
|
# Find the kernel name inside the chroot
|
|
_extramodules=extramodules-3.0-lts
|
|
_kver="$(cat /lib/modules/${_extramodules}/version)"
|
|
|
|
pkgname=tiacx-lts
|
|
pkgver=20080210
|
|
pkgrel=5
|
|
pkgdesc="OpenSource module for Texas Instruments ACX100/ACX111 wireless chips. For stock chakra kernel"
|
|
arch=(i686 x86_64)
|
|
url="http://acx100.sourceforge.net/"
|
|
license=('MPL')
|
|
depends=('wireless_tools' 'linux-lts>=3.0' 'linux-lts<3.1' 'tiacx-firmware')
|
|
makedepends=('linux-lts-headers')
|
|
install=acx.install
|
|
source=(http://downloads.sourceforge.net/sourceforge/acx100/acx-$pkgver.tar.bz2
|
|
kernel-2.6.27.patch
|
|
kernel-2.6.30.patch
|
|
kernel-2.6.31.patch
|
|
kernel-2.6.33.patch)
|
|
md5sums=('7d5ce3215708e4e9f95cf567a9ee3a12'
|
|
'9895f72f8d0c84956b0f6c3b16df0fe8'
|
|
'e2900aee839ce711a7f7606b3e3de36e'
|
|
'dbcb276d77df7801cef58a85c18dfe94'
|
|
'9cd35ea33b8abdd2e4efec485b05477e')
|
|
|
|
build() {
|
|
cd $startdir/src/acx-$pkgver
|
|
patch -p1 -i ../kernel-2.6.27.patch
|
|
patch -p0 -i ../kernel-2.6.30.patch
|
|
patch -p1 -i ../kernel-2.6.31.patch
|
|
patch -p0 -i ../kernel-2.6.33.patch
|
|
|
|
make -C /lib/modules/${_kver}/build M=`pwd`
|
|
install -D acx.ko $pkgdir/lib/modules/$_extramodules/acx.ko
|
|
sed -i -e "s/EXTRAMODULES='.*'/EXTRAMODULES='${_extramodules}'/" ${startdir}/*.install
|
|
}
|
|
|