mirror of
https://gitdl.cn/https://github.com/chakralinux/core.git
synced 2025-01-23 18:14:54 +08:00
38 lines
1009 B
Bash
38 lines
1009 B
Bash
#
|
|
# Core Packages for Chakra, part of chakra-project.org
|
|
#
|
|
# maintainer abveritas@chakra-project.org
|
|
|
|
pkgname=usbutils
|
|
pkgver=005
|
|
pkgrel=2
|
|
pkgdesc="USB Device Utilities"
|
|
arch=(i686 x86_64)
|
|
license=('GPL')
|
|
groups=('base')
|
|
depends=('libusb' 'hwids')
|
|
optdepends=('python2: for lsusb.py usage'
|
|
'coreutils: for lsusb.py usage'
|
|
'wget: for update-usbids.sh usage')
|
|
url="http://linux-usb.sourceforge.net/"
|
|
source=("http://chakra-linux.org/sources/${pkgname}/${pkgname}-${pkgver}.tar.bz2"
|
|
fix-python2.patch)
|
|
md5sums=('6a21f7b6c02b76df5e8a7c208d746654'
|
|
'45766196895b4cc50b53cd56e1bbf3d1')
|
|
|
|
build() {
|
|
cd $srcdir/$pkgname-$pkgver
|
|
# patch lsusb.py to use correct usb.ids file and python2 interpreter
|
|
patch -Np1 -i $srcdir/fix-python2.patch
|
|
./configure --prefix=/usr --datadir=/usr/share/hwdata --disable-zlib
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd $srcdir/$pkgname-$pkgver
|
|
make DESTDIR=$pkgdir install
|
|
# this is now in the hwids package
|
|
rm -rf $pkgdir/usr/{share/hwdata,sbin}
|
|
}
|
|
|