mirror of
https://gitdl.cn/https://github.com/chakralinux/core.git
synced 2025-01-23 18:14:54 +08:00
39 lines
906 B
Bash
39 lines
906 B
Bash
#
|
|
# Core Packages for Chakra, part of chakra-project.org
|
|
#
|
|
# maintainer abveritas[at]chakra-project[dot]org>
|
|
|
|
pkgname=wget
|
|
pkgver=1.14
|
|
pkgrel=1
|
|
pkgdesc="A network utility to retrieve files from the Web"
|
|
arch=('x86_64')
|
|
url="http://www.gnu.org/software/wget/wget.html"
|
|
license=('GPL3')
|
|
groups=('base')
|
|
depends=('glibc' 'openssl' 'libidn' 'util-linux')
|
|
optdepends=('ca-certificates: HTTPS downloads')
|
|
backup=('etc/wgetrc')
|
|
install=wget.install
|
|
source=("ftp://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.xz")
|
|
md5sums=('316f6f59292c9098ad81fd54f658c579')
|
|
|
|
build() {
|
|
cd "${srcdir}/${pkgname}-${pkgver}"
|
|
|
|
./configure -with-ssl=openssl --prefix=/usr --sysconfdir=/etc --enable-nls
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd "${srcdir}/${pkgname}-${pkgver}"
|
|
make DESTDIR="${pkgdir}" install
|
|
|
|
cat >> "$pkgdir/etc/wgetrc" <<EOF
|
|
|
|
# default root certs location
|
|
ca_certificate=/etc/ssl/certs/ca-certificates.crt
|
|
EOF
|
|
|
|
}
|