mirror of
https://gitdl.cn/https://github.com/chakralinux/core.git
synced 2025-01-24 02:22:15 +08:00
29 lines
1.1 KiB
Bash
29 lines
1.1 KiB
Bash
#
|
|
# Core Packages for Chakra, part of chakra-project.org
|
|
#
|
|
# maintainer: abveritas@chakra-project.org
|
|
|
|
pkgname=mkinitcpio
|
|
pkgver=0.10
|
|
pkgrel=2
|
|
pkgdesc="Modular initramfs image creation utility"
|
|
arch=('any')
|
|
url="http://www.archlinux.org/"
|
|
license=('GPL')
|
|
depends=('awk' 'mkinitcpio-busybox>=1.19.4-2' 'kmod' 'util-linux>=2.21' 'libarchive' 'coreutils'
|
|
'bash' 'findutils' 'grep' 'filesystem>=2011.10-1' 'file' 'gzip' 'systemd')
|
|
optdepends=('xz: Use lzma or xz compression for the initramfs image'
|
|
'bzip2: Use bzip2 compression for the initramfs image'
|
|
'lzop: Use lzo compression for the initramfs image'
|
|
'mkinitcpio-nfs-utils: Support for root filesystem on NFS')
|
|
backup=('etc/mkinitcpio.conf')
|
|
source=("ftp://ftp.archlinux.org/other/$pkgname/$pkgname-$pkgver.tar.gz"{,.sig})
|
|
install=mkinitcpio.install
|
|
sha256sums=('cd3526b135ede8ca60e05222b1e86cdf3a917947d4fd5b6e6a0a34ec408bc494'
|
|
'21bd8a75203d15706fd66bfc9520ea1eb728736ee8f6c6a595f63f997b2673e3')
|
|
|
|
package() {
|
|
make -C "$pkgname-$pkgver" DESTDIR="$pkgdir" install
|
|
}
|
|
|