core/gnutls/PKGBUILD
2018-01-18 21:54:33 +01:00

45 lines
1.5 KiB
Bash

# Contributions from Arch: https://projects.archlinux.org/svntogit/packages.git/tree/trunk?h=packages/gnutls
pkgname=gnutls
pkgver=3.5.17
pkgrel=1
pkgdesc="A library which provides a secure layer over a reliable transport layer"
arch=('x86_64')
license=('GPL3' 'LGPL2.1')
url="http://www.gnutls.org/"
install=gnutls.install
options=('!zipman')
depends=('gcc-libs' 'libidn' 'libtasn1' 'libunistring' 'readline' 'zlib' 'nettle' 'p11-kit' 'libidn')
optdepends=('guile: for use with Guile bindings')
source=(https://www.gnupg.org/ftp/gcrypt/gnutls/v3.5/${pkgname}-${pkgver}.tar.xz{,.sig})
sha256sums=('86b142afef587c118d63f72ccf307f3321dbc40357aae528202b65d913d20919'
'SKIP')
validpgpkeys=('0424D4EE81A0E3D119C6F835EDA21E94B565716F'
'1F42418905D8206AA754CCDC29EE58B996865171')
build() {
cd ${pkgname}-${pkgver}
./configure --prefix=/usr \
--with-zlib \
--without-idn \
--disable-static \
--enable-guile --with-guile-site-dir=no \
--with-default-trust-store-pkcs11="pkcs11:model=p11-kit-trust;manufacturer=PKCS%2311%20Kit"
make
}
check() {
cd ${pkgname}-${pkgver}
make -j1 check | true
}
package() {
cd ${pkgname}-${pkgver}
make DESTDIR="${pkgdir}" install
# lots of .png files are put into infodir and are gzipped by makepkg! this needs to be fixed by using !zipman
# gzip -9 all files in infodir and manpages manually
find "$pkgdir/usr/share/info" -name '*.info*' -exec gzip -9 {} \;
find "$pkgdir/usr/share/man" -exec gzip -9 {} \;
}