mirror of
https://gitdl.cn/https://github.com/chakralinux/core.git
synced 2025-02-10 08:34:37 +08:00
29 lines
844 B
Bash
29 lines
844 B
Bash
pkgname=gptfdisk
|
|
pkgver=1.0.3
|
|
pkgrel=2
|
|
pkgdesc="A text-mode partitioning tool that works on Globally Unique Identifier (GUID) Partition Table (GPT) disks"
|
|
arch=('x86_64')
|
|
url="http://www.rodsbooks.com/gdisk/"
|
|
license=('GPL2')
|
|
depends=('gcc-libs' 'util-linux' 'popt' 'icu' 'ncurses')
|
|
provides=("gdisk=$pkgver")
|
|
conflicts=('gdisk')
|
|
replaces=('gdisk')
|
|
source=("http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz")
|
|
md5sums=('07b625a583b66c8c5840be5923f3e3fe')
|
|
|
|
build() {
|
|
cd "$srcdir/$pkgname-$pkgver"
|
|
|
|
make
|
|
}
|
|
|
|
package () {
|
|
cd "$srcdir/$pkgname-$pkgver"
|
|
|
|
install -d "$pkgdir"/usr/{bin,share/{doc/gdisk,man/man8}}
|
|
install -t "$pkgdir/usr/bin" {,c,s}gdisk fixparts
|
|
install -m644 -t "$pkgdir/usr/share/man/man8" {{,c,s}gdisk,fixparts}.8
|
|
install -m644 -t "$pkgdir/usr/share/doc/gdisk" README NEWS
|
|
}
|