core/iw/PKGBUILD

32 lines
754 B
Bash

#
# Core Packages for Chakra, part of chakra-project.org
#
# maintainer abveritas[at]chakra-project[dot]org>
pkgname=iw
pkgver=3.8
pkgrel=1
pkgdesc="nl80211 based CLI configuration utility for wireless devices"
arch=('x86_64')
url="http://wireless.kernel.org/en/users/Documentation/iw"
license=('GPL')
depends=('libnl')
makedepends=('linux-api-headers' 'pkg-config')
source=("https://www.kernel.org/pub/software/network/$pkgname/$pkgname-$pkgver.tar.xz"
'version-sh.patch')
md5sums=('2aae163b7c3b581b7d94f34a5d3e47d8'
'9e8d3294410721165571020a671121da')
build() {
cd "$srcdir"/$pkgname-$pkgver
patch -p0 -i "${srcdir}"/version-sh.patch
make
}
package() {
cd "$srcdir"/$pkgname-$pkgver
make DESTDIR="$pkgdir" install
}