mirror of
https://gitdl.cn/https://github.com/chakralinux/core.git
synced 2025-02-09 14:47:15 +08:00
40 lines
1.1 KiB
Bash
40 lines
1.1 KiB
Bash
# Contributions from Arch: https://projects.archlinux.org/svntogit/packages.git/tree/trunk?h=packages/kemoticons
|
|
|
|
pkgname=kemoticons
|
|
pkgver=5.55.0
|
|
pkgrel=1
|
|
pkgdesc='Support for emoticons and emoticons themes'
|
|
arch=('x86_64')
|
|
url='https://projects.kde.org/projects/frameworks/kemoticons'
|
|
license=('LGPL')
|
|
depends=('karchive' 'kservice')
|
|
makedepends=("extra-cmake-modules>=5.55.0" 'python3')
|
|
groups=('kf5')
|
|
options=("debug")
|
|
source=("https://download.kde.org/stable/frameworks/${pkgver%.*}/${pkgname}-${pkgver}.tar.xz"{,.sig})
|
|
sha256sums=('b06e06f5868a9f776ed73a830773565af0814486d1b8602a06a1c99a9c107d0f'
|
|
'SKIP')
|
|
validpgpkeys=(53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB) # David Faure <faure@kde.org>
|
|
|
|
prepare() {
|
|
mkdir -p build
|
|
}
|
|
|
|
build() {
|
|
cd build
|
|
cmake ../${pkgname}-${pkgver} \
|
|
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
|
|
-DCMAKE_INSTALL_PREFIX=/usr \
|
|
-DKDE_INSTALL_LIBDIR=lib \
|
|
-DKDE_INSTALL_SYSCONFDIR=/etc \
|
|
-DKDE_INSTALL_LIBEXECDIR=lib \
|
|
-DBUILD_TESTING=OFF \
|
|
-DKDE_INSTALL_USE_QT_SYS_PATHS=ON "$@"
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd build
|
|
make DESTDIR="${pkgdir}" install
|
|
}
|