mirror of
https://gitdl.cn/https://github.com/chakralinux/core.git
synced 2025-02-03 07:17:23 +08:00
28 lines
783 B
Bash
28 lines
783 B
Bash
# Contributions from Arch:
|
|
# Maintainer: Antonio Rojas <arojas@archlinux.org>
|
|
# Contributor: Adam Fontenot <fontenot@ucla.edu>
|
|
|
|
pkgname=libheif
|
|
pkgver=1.3.2
|
|
pkgrel=1
|
|
pkgdesc="HEIF file format decoder and encoder"
|
|
arch=(x86_64)
|
|
url="https://github.com/strukturag/libheif"
|
|
license=(GPL3)
|
|
makedepends=(x265 libjpeg libpng libde265)
|
|
depends=(libde265 x265)
|
|
optdepends=('libjpeg: for heif-convert and heif-enc' 'libpng: for heif-convert and heif-enc')
|
|
source=(https://github.com/strukturag/libheif/releases/download/v$pkgver/libheif-$pkgver.tar.gz)
|
|
sha256sums=('a9e12a693fc172baa16669f427063edd7bf07964a1cb623ee57cd056c06ee3fc')
|
|
|
|
build() {
|
|
cd $pkgname-$pkgver
|
|
./configure --prefix=/usr --enable-static=no
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd $pkgname-$pkgver
|
|
make DESTDIR="$pkgdir" install
|
|
}
|