core/libinput/PKGBUILD
2018-11-25 13:33:12 +01:00

38 lines
1.2 KiB
Bash

#Contributions from Arch: https://projects.archlinux.org/svntogit/packages.git/tree/trunk?h=packages/libinput
pkgname=libinput
pkgver=1.12.3
pkgrel=1
pkgdesc="Input device management and event handling library"
arch=(x86_64)
url="http://www.freedesktop.org/wiki/Software/libinput/"
license=(custom:X11)
depends=('mtdev' 'systemd' 'libevdev' 'libwacom')
makedepends=('gtk3' 'meson') # To build docs (not recommended by upstream) add these deps: 'doxygen' 'graphviz' 'python-sphinx' 'python-recommonmark'
optdepends=('gtk3: libinput debug-gui'
'python-pyudev: libinput measure'
'python-evdev: libinput measure')
install=libinput.install
options=('!libtool')
source=(http://freedesktop.org/software/$pkgname/$pkgname-$pkgver.tar.xz{,.sig})
sha256sums=('f266ff861a2e7a97e1402c4345e3547b900efde68adbd40e56403e2617fee255'
'SKIP')
validpgpkeys=('3C2C43D9447D5938EF4551EBE23B7E70B467F0BF') # Peter Hutterer (Who-T) <office@who-t.net>
build() {
chakra-meson $pkgname-$pkgver build \
-Dudev-dir=/usr/lib/udev \
-Dtests=false \
-Ddocumentation=false
ninja -C build
}
package() {
DESTDIR=$pkgdir ninja -C build install
install -Dvm644 $pkgname-$pkgver/COPYING \
$pkgdir/usr/share/licenses/$pkgname/LICENSE
}