mirror of
https://gitdl.cn/https://github.com/chakralinux/core.git
synced 2025-02-03 08:07:15 +08:00
26 lines
641 B
Bash
26 lines
641 B
Bash
# maintainer: Neophytos Kolokotronis <tetris4@gmail.com>
|
|
|
|
pkgname=perl-capture-tiny
|
|
_pkgname=Capture-Tiny
|
|
pkgver=0.30
|
|
pkgrel=1
|
|
pkgdesc="Capture STDOUT and STDERR from Perl, XS or external programs"
|
|
arch=('x86_64')
|
|
license=(PerlArtistic GPL)
|
|
depends=(perl)
|
|
url="https://github.com/dagolden/Capture-Tiny"
|
|
options=('!emptydirs')
|
|
source=("https://github.com/dagolden/$_pkgname/archive/release-$pkgver.tar.gz")
|
|
md5sums=('6f048bd5ddfeeb78b925949b7addee8c')
|
|
|
|
build() {
|
|
cd $_pkgname-release-$pkgver
|
|
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd $_pkgname-release-$pkgver
|
|
make DESTDIR="$pkgdir" install
|
|
}
|