mirror of
https://gitdl.cn/https://github.com/chakralinux/core.git
synced 2025-02-03 07:37:14 +08:00
39 lines
891 B
Bash
39 lines
891 B
Bash
|
|
pkgname=qt5-svg
|
|
pkgver=5.12.1
|
|
pkgrel=1
|
|
arch=('x86_64')
|
|
url='http://qt-project.org/'
|
|
license=('GPL3' 'LGPL' 'FDL' 'custom')
|
|
pkgdesc='Classes for displaying the contents of SVG files'
|
|
depends=('qt5-base')
|
|
makedepends=()
|
|
groups=('qt5')
|
|
options=('debug')
|
|
_pkgfqn="${pkgname/5-/}-everywhere-src-${pkgver}"
|
|
source=("http://download.qt.io/official_releases/qt/${pkgver%.*}/$pkgver/submodules/${_pkgfqn}.tar.xz")
|
|
md5sums=('c9d4b0c83999d260d380c8b252636aa4')
|
|
|
|
prepare() {
|
|
mkdir -p build
|
|
}
|
|
|
|
build() {
|
|
cd build
|
|
|
|
qmake-qt5 ../${_pkgfqn}
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd build
|
|
make INSTALL_ROOT="$pkgdir" install
|
|
|
|
# Drop QMAKE_PRL_BUILD_DIR because reference the build dir
|
|
find "${pkgdir}/usr/lib" -type f -name '*.prl' \
|
|
-exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
|
|
|
|
install -d "$pkgdir"/usr/share/licenses
|
|
ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/${pkgname}
|
|
}
|