mirror of
https://gitdl.cn/https://github.com/chakralinux/core.git
synced 2025-02-03 07:07:12 +08:00
27 lines
724 B
Bash
27 lines
724 B
Bash
#
|
|
# Platform Packages for Chakra, part of chakra-project.org
|
|
#
|
|
# contributor (x86_64): Giuseppe Calà <jiveaxe@gmail.com>
|
|
|
|
# include global config
|
|
source ../_buildscripts/${current_repo}-${_arch}-cfg.conf
|
|
|
|
pkgname=tsocks
|
|
pkgver=1.8beta5
|
|
pkgrel=2
|
|
pkgdesc="A transparent SOCKS proxying library"
|
|
arch=('i686' 'x86_64')
|
|
arch=(i686 x86_64)
|
|
url="http://tsocks.sourceforge.net"
|
|
license=("GPL")
|
|
depends=('glibc')
|
|
source=(http://downloads.sourceforge.net/tsocks/tsocks-$pkgver.tar.gz)
|
|
md5sums=('51caefd77e5d440d0bbd6443db4fc0f8')
|
|
|
|
build() {
|
|
cd ${srcdir}/tsocks-1.8
|
|
./configure --prefix=/usr --sysconfdir=/etc --mandir=/usr/share/man --libdir=/usr/lib || return 1
|
|
make || return 1
|
|
make DESTDIR=${pkgdir} install || return 1
|
|
}
|