mirror of
https://gitdl.cn/https://github.com/chakralinux/core.git
synced 2025-02-10 08:54:36 +08:00
41 lines
871 B
Bash
41 lines
871 B
Bash
# Contributions from Arch:
|
|
# Maintainer: Sébastien Luttringer <seblu@seblu.net>
|
|
|
|
pkgname=wayland-protocols
|
|
pkgver=1.17
|
|
pkgrel=1
|
|
pkgdesc='Specifications of extended Wayland protocols'
|
|
arch=('any')
|
|
url='https://wayland.freedesktop.org/'
|
|
license=('MIT')
|
|
makedepends=('wayland')
|
|
validpgpkeys=('8307C0A224BABDA1BABD0EB9A6EEEC9E0136164A' # Jonas Ådahl
|
|
'A66D805F7C9329B4C5D82767CCC4F07FAC641EFF') # Daniel Stone
|
|
source=("https://wayland.freedesktop.org/releases/$pkgname-$pkgver.tar.xz"{,.sig})
|
|
sha1sums=('7d2569c838c776545e3eb1b1049b9c37178aae24'
|
|
'SKIP')
|
|
|
|
prepare() {
|
|
cd $pkgname-$pkgver
|
|
}
|
|
|
|
build() {
|
|
cd $pkgname-$pkgver
|
|
|
|
./configure --prefix=/usr
|
|
make
|
|
}
|
|
|
|
check() {
|
|
cd $pkgname-$pkgver
|
|
|
|
make check
|
|
}
|
|
|
|
package() {
|
|
cd $pkgname-$pkgver
|
|
|
|
make DESTDIR="$pkgdir" install
|
|
install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m 644 COPYING
|
|
}
|