mirror of
https://gitdl.cn/https://github.com/chakralinux/core.git
synced 2025-02-03 06:47:14 +08:00
36 lines
925 B
Bash
36 lines
925 B
Bash
# Part of the X.org group
|
|
# Maintainer: Neophytos Kolokotronis <tetris4 AT gmail DOT com>
|
|
|
|
pkgname=xcb-util-keysyms
|
|
pkgver=0.4.0
|
|
pkgrel=1
|
|
pkgdesc="Utility libraries for XC Binding - Standard X key constants and conversion to/from keycodes"
|
|
arch=('x86_64')
|
|
url="http://xcb.freedesktop.org"
|
|
license=('custom')
|
|
depends=('libxcb')
|
|
makedepends=('xorg-util-macros')
|
|
source=("http://xcb.freedesktop.org/dist/${pkgname}-${pkgver}.tar.bz2"
|
|
'LICENSE')
|
|
sha256sums=('0ef8490ff1dede52b7de533158547f8b454b241aa3e4dcca369507f66f216dd9'
|
|
'ded299aa179dcf0d885bf89274a4db77a530e03f9f5e7cf1c3c4ef1d60e914b9')
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
./configure --prefix=/usr --disable-static
|
|
make
|
|
}
|
|
|
|
check() {
|
|
cd ${pkgname}-${pkgver}
|
|
make check
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
make DESTDIR="${pkgdir}" install
|
|
|
|
install -D -m644 "${srcdir}/LICENSE" \
|
|
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
|
|
}
|