mirror of
https://gitdl.cn/https://github.com/chakralinux/core.git
synced 2025-01-24 02:22:15 +08:00
40 lines
1.2 KiB
Bash
Executable File
40 lines
1.2 KiB
Bash
Executable File
#
|
|
# Chakra Packages for Chakra, part of chakra-project.org
|
|
#
|
|
# maintainer (i686): Phil Miller <philm[at]chakra-project[dog]org>
|
|
# maintainer (x86_64): Manuel Tortosa <manutortosa[at]chakra-project[dot]org>
|
|
|
|
pkgname=pmtools
|
|
pkgver=20110323
|
|
pkgrel=2
|
|
pkgdesc="A small collection of ACPI power management test and investigation tools"
|
|
arch=('i686' 'x86_64')
|
|
url="http://acpi.sourceforge.net/dsdt/index.php"
|
|
license=('GPL2')
|
|
source=(http://ftp.kernel.org/pub/linux/kernel/people/lenb/acpi/utils/$pkgname-$pkgver.tar.bz2)
|
|
md5sums=('9ed64a1c04bb9597257786de034a77a9')
|
|
|
|
build() {
|
|
cd $srcdir/$pkgname
|
|
patch -p1 <<EOF
|
|
diff -wbBur pmtools/turbostat/Makefile pmtools.my/turbostat/Makefile
|
|
--- pmtools/turbostat/Makefile 2010-11-24 05:36:50.000000000 +0000
|
|
+++ pmtools.my/turbostat/Makefile 2010-11-24 16:42:05.000000000 +0000
|
|
@@ -1,3 +1,5 @@
|
|
+all: turbostat
|
|
+
|
|
turbostat : turbostat.c
|
|
|
|
clean :
|
|
EOF
|
|
|
|
make
|
|
(cd madt && make)
|
|
|
|
install -D -m755 acpidump/acpidump $pkgdir/usr/sbin/acpidump
|
|
install -D -m755 acpixtract/acpixtract $pkgdir/usr/sbin/acpixtract
|
|
install -D -m755 madt/madt $pkgdir/usr/sbin/madt
|
|
install -D -m755 pmtest/pmtest $pkgdir/usr/sbin/pmtest
|
|
install -D -m755 turbostat/turbostat $pkgdir/usr/sbin/turbostat
|
|
}
|