mirror of
https://gitdl.cn/https://github.com/chakralinux/core.git
synced 2025-02-03 23:57:13 +08:00
49 lines
1.2 KiB
Bash
49 lines
1.2 KiB
Bash
#
|
|
# Platform Packages for Chakra, part of chakra-project.org
|
|
#
|
|
# contributor (x86_64): Giuseppe Calà <jiveaxe@gmail.com>
|
|
|
|
# include global config
|
|
source ../_buildscripts/${current_repo}-${_arch}-cfg.conf
|
|
|
|
pkgname=libosip2
|
|
pkgver=3.3.0
|
|
pkgrel=1
|
|
pkgdesc="oSIP is an implementation of SIP"
|
|
arch=('i686' 'x86_64')
|
|
url="http://www.gnu.org/software/osip/"
|
|
license=('LGPL')
|
|
depends=(glibc)
|
|
options=(!emptydirs !libtool)
|
|
source=(http://ftp.gnu.org/gnu/osip/libosip2-${pkgver/_/-}.tar.gz)
|
|
md5sums=('81493bb4d4ae6d55b71a0d4369339125')
|
|
|
|
build() {
|
|
cd $srcdir/libosip2-${pkgver/_/-}/
|
|
|
|
patch -p1 <<EOF
|
|
diff -wbBur libosip2-3.1.0/src/osip2/port_sema.c libosip2-3.1.0.my/src/osip2/port_sema.c
|
|
--- libosip2-3.1.0/src/osip2/port_sema.c 2007-06-05 14:17:50.000000000 +0400
|
|
+++ libosip2-3.1.0.my/src/osip2/port_sema.c 2008-10-22 17:47:37.000000000 +0400
|
|
@@ -22,6 +22,14 @@
|
|
#include <stdlib.h>
|
|
#include <stdio.h>
|
|
|
|
+union semun
|
|
+{
|
|
+ int val;
|
|
+ struct semid_ds *buf;
|
|
+ unsigned short int *array;
|
|
+ struct seminfo *__buf;
|
|
+};
|
|
+
|
|
#include <osip2/internal.h>
|
|
|
|
#include <osip2/internal.h>
|
|
EOF
|
|
|
|
./configure --prefix=/usr --disable-semaphore --enable-sysv
|
|
make || return 1
|
|
make DESTDIR=$pkgdir install
|
|
}
|