desktop/granatier/PKGBUILD

35 lines
922 B
Bash

# Contributions from Arch: https://www.archlinux.org/packages/extra/x86_64/kdegames-granatier/
# Include global configuration
source ../kdeapps.conf
pkgname=granatier
pkgver=${_kdever}
pkgrel=1
pkgdesc="Granatier is a clone of the classic Bomberman game, inspired by the Clanbomber clone"
arch=('x86_64')
url='http://kde.org/applications/games/granatier/'
license=('GPL' 'LGPL' 'FDL')
depends=('knotifyconfig' 'libkdegames')
makedepends=('extra-cmake-modules' 'kdoctools' 'python3')
replaces=('kdegames-granatier')
conflicts=('kdegames-granatier')
groups=('kde' 'kde-uninstall' 'kde-applications' 'kdegames')
options=('docs' 'debug')
source=("$_mirror/${pkgname}-$_kdever.tar.xz")
sha256sums=(`grep ${pkgname}-$_kdever.tar.xz ../checksums.txt | cut -d " " -f1`)
prepare() {
mkdir -p build
}
build() {
cd build
cmake_kf5 ../${pkgname}-${pkgver}
make
}
package() {
cd build
make DESTDIR=${pkgdir} install
}