mirror of
https://gitdl.cn/https://github.com/chakralinux/desktop.git
synced 2025-01-24 02:22:13 +08:00
35 lines
1007 B
Bash
35 lines
1007 B
Bash
# Contributions from Arch: https://www.archlinux.org/packages/extra/x86_64/telepathy-kde-integration-module/
|
|
# Include global configuration
|
|
source ../kdeapps.conf
|
|
|
|
pkgname=ktp-kded-module
|
|
pkgver=${_kdever}
|
|
pkgrel=1
|
|
pkgdesc="Workspace integration module - provides several plugins like auto-away, the infamous 'Now listening to...' and also an error handler"
|
|
arch=('x86_64')
|
|
url="https://community.kde.org/Real-Time_Communication_and_Collaboration"
|
|
license=('GPL')
|
|
depends=('ktp-common-internals' 'kidletime')
|
|
makedepends=('extra-cmake-modules' 'kdoctools' 'python3')
|
|
provides=('ktp-kded-integration-module')
|
|
replaces=('ktp-kded-integration-module')
|
|
conflicts=('ktp-kded-integration-module')
|
|
groups=('kde-telepathy')
|
|
source=("$_mirror/${pkgname}-$_kdever.tar.xz")
|
|
sha256sums=(`grep ${pkgname}-$_kdever.tar.xz ../checksums.txt | cut -d " " -f1`)
|
|
|
|
prepare() {
|
|
mkdir -p build
|
|
}
|
|
|
|
build() {
|
|
cd build
|
|
cmake_kf5 ../${pkgname}-${pkgver}
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd build
|
|
make DESTDIR=${pkgdir} install
|
|
}
|