mirror of
https://gitdl.cn/https://github.com/chakralinux/desktop.git
synced 2025-01-24 02:22:13 +08:00
38 lines
1.2 KiB
Bash
38 lines
1.2 KiB
Bash
pkgname=stellarium
|
|
pkgver=0.15.0
|
|
pkgrel=2
|
|
pkgdesc="A stellarium with great graphics and a nice database of sky-objects"
|
|
arch=('x86_64')
|
|
url="http://www.stellarium.org/"
|
|
screenshot=('http://www.stellarium.org/img/screenshots/0.10-from-mars.jpg')
|
|
license=('GPL2')
|
|
depends=('libpng' 'libgl' 'glu' 'openssl' 'zlib' 'gettext' 'qt5-script'
|
|
'xdg-utils' 'freetype2' 'phonon-qt5' 'qt5-multimedia' 'desktop-file-utils' 'qt5-serialport')
|
|
makedepends=('cmake' 'boost' 'mesa' 'mesa-libgl' 'qt5-tools')
|
|
categories=('education')
|
|
source=("http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz")
|
|
sha256sums=('74d0e3a69fcbaf1c6278f601a44497fd3e9f2de7dfa11a60197d3afb68288746')
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
cmake . -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=RELEASE -DENABLE_SOUND=1
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
make DESTDIR="${pkgdir}" install
|
|
|
|
# install desktop file
|
|
install -Dm644 data/stellarium.desktop \
|
|
"${pkgdir}/usr/share/applications/stellarium.desktop"
|
|
|
|
# install desktop icons
|
|
for i in 16 32 48 64 128 256 512; do
|
|
install -Dm644 data/icons/${i}x${i}/stellarium.png \
|
|
"${pkgdir}/usr/share/icons/hicolor/${i}x${i}/apps/stellarium.png"
|
|
done
|
|
}
|