desktop/aircrack-ng/PKGBUILD
2018-11-29 12:37:59 +01:00

31 lines
740 B
Bash

pkgname=aircrack-ng
_pkgver=1.4
pkgver=${_pkgver//-/}
pkgrel=1
pkgdesc="A key cracker for the 802.11 WEP and WPA-PSK protocols"
arch=('x86_64')
url="http://www.aircrack-ng.org"
license=('GPL2')
depends=('openssl' 'sqlite3' 'iw' 'net-tools' 'wireless_tools' 'ethtool')
categories=('network')
source=("http://download.aircrack-ng.org/${pkgname}-${_pkgver}.tar.gz")
sha1sums=('22bae2c6f21e463df62b4c06c9c3c45c42a9b4ea')
build() {
cd $pkgname-$_pkgver
./autogen.sh
./configure --prefix=/usr
make sqlite=true experimental=true
}
package() {
cd $pkgname-$_pkgver
make DESTDIR="$pkgdir" sqlite=true experimental=true \
bindir=/usr/bin sbindir=/usr/bin mandir=/usr/share/man/man1/ \
smandir=/usr/share/man/man8/ install
}