desktop/antlr4-runtime/PKGBUILD

24 lines
485 B
Bash

pkgname=antlr4-runtime
pkgver=4.7.2
pkgrel=1
pkgdesc='Antlr C++ runtime'
url='https://www.antlr.org/'
arch=('x86_64')
depends=('gcc-libs')
license=('BSD')
makedepends=('cmake')
source=("https://www.antlr.org/download/antlr4-cpp-runtime-${pkgver}-source.zip")
sha256sums=('8631a39116684638168663d295a969ad544cead3e6089605a44fea34ec01f31a')
build() {
mkdir build
cd build
cmake .. -DCMAKE_INSTALL_PREFIX=/usr
make
}
package() {
cd build
make DESTDIR="${pkgdir}/" install
}