mirror of
https://gitdl.cn/https://github.com/chakralinux/desktop.git
synced 2025-01-23 18:14:51 +08:00
28 lines
878 B
Bash
28 lines
878 B
Bash
pkgname=cb2bib
|
|
pkgver=1.9.9
|
|
pkgrel=1
|
|
pkgdesc="A tool for parsing clipboard data into BibTeX bibliographic database files"
|
|
arch=('x86_64')
|
|
url="http://www.molspaces.com/cb2bib/"
|
|
license=('GPL3')
|
|
depends=('desktop-file-utils' 'lzo2' 'qt5-base' 'qt5-x11extras' 'qt5-webkit')
|
|
makedepends=('qt5-tools')
|
|
optdepends=('openssl: network reference query support'
|
|
'perl-exiftool: meta data support'
|
|
'texlive-latex3: file correctness checking; bib2pdf printing'
|
|
'xpdf: pdftotext support')
|
|
categories=('office')
|
|
source=(http://www.molspaces.com/dl/progs/$pkgname-$pkgver.tar.gz)
|
|
sha256sums=('873c9f7f246469c0367982a7146e6aab301891baa5fbe1aa63466462d2fea78b')
|
|
|
|
build() {
|
|
cd "$srcdir/$pkgname-$pkgver"
|
|
./configure --prefix /usr --qmakepath /usr/bin/qmake-qt5
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd "$srcdir/$pkgname-$pkgver"
|
|
make INSTALL_ROOT="$pkgdir" install
|
|
}
|