mirror of
https://gitdl.cn/https://github.com/chakralinux/desktop.git
synced 2025-02-03 03:17:15 +08:00
36 lines
793 B
Bash
36 lines
793 B
Bash
pkgname=chakra-heritage-themes
|
|
pkgver=2018.12
|
|
pkgrel=2
|
|
pkgdesc='Chakra Plasma 5 Look & Feel theme files'
|
|
url='https://www.chakralinux.org'
|
|
arch=('x86_64')
|
|
license=('LGPL')
|
|
# remember to set the wallpaper name and resolution!! in plasma/heritage/metadata.desktop
|
|
depends=('plasma-framework' 'chakra-wallpapers-giau')
|
|
makedepends=('extra-cmake-modules')
|
|
|
|
_gitsha='76dcc0c388cfd1ae95efb038adbf86df753e64d5'
|
|
source=("git+https://code.chakralinux.org/chakra/tools/heritage.git#commit=${_gitsha}")
|
|
sha256sums=('SKIP')
|
|
|
|
prepare() {
|
|
mkdir -p build
|
|
cd $srcdir/heritage
|
|
}
|
|
|
|
build() {
|
|
cd build
|
|
|
|
cmake ../heritage \
|
|
-DCMAKE_BUILD_TYPE=Release \
|
|
-DCMAKE_INSTALL_PREFIX=/usr \
|
|
-DKDE_INSTALL_USE_QT_SYS_PATHS=ON
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd build
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
}
|