mirror of
https://gitdl.cn/https://github.com/chakralinux/desktop.git
synced 2025-02-03 02:27:15 +08:00
29 lines
621 B
Bash
29 lines
621 B
Bash
pkgname=devil
|
|
_pkgname=DevIL
|
|
pkgver=1.8.0
|
|
pkgrel=3
|
|
pkgdesc="Library for reading several different image formats"
|
|
arch=('x86_64')
|
|
url="http://openil.sourceforge.net/"
|
|
depends=('libpng' 'libmng' 'jasper' 'lcms' 'openexr')
|
|
makedepends=('cmake')
|
|
install=devil.install
|
|
options=('!docs' '!emptydirs')
|
|
license=('GPL')
|
|
source=("http://downloads.sourceforge.net/openil/DevIL-$pkgver.tar.gz")
|
|
md5sums=('4d8c21aa4822ac86d77e44f8d7c9becd')
|
|
|
|
build() {
|
|
cd $_pkgname/$_pkgname
|
|
|
|
mkdir -p build/
|
|
cd build/
|
|
cmake -DCMAKE_INSTALL_PREFIX=/usr ..
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd $_pkgname/$_pkgname/build
|
|
make DESTDIR=$pkgdir install
|
|
}
|