mirror of
https://gitdl.cn/https://github.com/chakralinux/desktop.git
synced 2025-01-23 18:14:51 +08:00
32 lines
790 B
Bash
32 lines
790 B
Bash
# Contributions from Arch: https://projects.archlinux.org/svntogit/packages.git/tree/trunk?h=packages/dssi
|
|
|
|
pkgname=dssi
|
|
pkgver=1.1.1
|
|
pkgrel=11
|
|
pkgdesc="An API for audio processing plugins & softsynths with UIs"
|
|
arch=('x86_64')
|
|
url="http://dssi.sourceforge.net/"
|
|
license=('LGPL' 'BSD' 'custom')
|
|
depends=('liblo' 'jack')
|
|
makedepends=('ladspa' 'qt')
|
|
source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
|
|
'license.txt')
|
|
md5sums=('619ab73c883b02dc37ddb37001591f8b'
|
|
'258ca4d0ca28c5c4d4675147621fac18')
|
|
|
|
build() {
|
|
cd "$srcdir/$pkgname-$pkgver"
|
|
|
|
./configure --prefix=/usr
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd "$srcdir/$pkgname-$pkgver"
|
|
|
|
make DESTDIR="$pkgdir" install
|
|
|
|
install -Dm644 "$srcdir/license.txt" \
|
|
"$pkgdir/usr/share/licenses/$pkgname/LICENSE"
|
|
}
|