mirror of
https://gitdl.cn/https://github.com/chakralinux/desktop.git
synced 2025-01-23 18:14:51 +08:00
33 lines
725 B
Bash
33 lines
725 B
Bash
pkgname=dvdauthor
|
|
pkgver=0.7.2
|
|
pkgrel=1
|
|
pkgdesc="DVD authoring tools"
|
|
arch=('x86_64')
|
|
url="http://dvdauthor.sourceforge.net/"
|
|
license=('GPL')
|
|
depends=('libdvdread' 'imagemagick' 'libxml2' 'libpng' 'fribidi')
|
|
categories=('multimedia')
|
|
source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
|
|
"imagemagick7.patch")
|
|
sha1sums=('0e605642140576bfb3e963414d77630d1c073a51'
|
|
'05724618c7553e5cb9fb684ec6e08f4070bba908')
|
|
|
|
prepare() {
|
|
cd $pkgname
|
|
patch -p1 -i $srcdir/imagemagick7.patch
|
|
autoreconf -vi
|
|
}
|
|
|
|
build() {
|
|
cd $pkgname
|
|
./configure --prefix=/usr \
|
|
--sysconfdir=/etc \
|
|
--with-imagemagick
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd $pkgname
|
|
make DESTDIR=$pkgdir install
|
|
}
|