desktop/extra-cmake-modules/PKGBUILD
Neophytos Kolokotronis 32e2fc564f KDE Apps 14.12
2015-02-19 22:29:49 +00:00

34 lines
783 B
Bash

# Contributions from Arch: https://projects.archlinux.org/svntogit/packages.git/tree/trunk/PKGBUILD?h=packages/extra-cmake-modules
source ../frameworks.conf
pkgname=extra-cmake-modules
pkgver=1.7.0
pkgrel=1
pkgdesc='Extra CMake modules'
arch=('x86_64')
url='https://projects.kde.org/projects/kdesupport/extra-cmake-modules'
license=('LGPL')
depends=('cmake')
makedepends=('python3-sphinx') # qt5-tools for QtHelp pages
source=("$KFServer/$KFVersion/${pkgname}-${pkgver}.tar.xz")
sha256sums=( $(getSum $pkgname) )
prepare() {
mkdir -p build
}
build() {
cd build
cmake ../${pkgname}-${pkgver} \
-DCMAKE_INSTALL_PREFIX=$KFInstallPrefix \
-DCMAKE_BUILD_TYPE=$KFBuildType \
-DBUILD_HTML_DOCS=OFF
make
}
package() {
cd build
make DESTDIR="${pkgdir}" install
}