desktop/freedroid/PKGBUILD
Adrian Chaves (Gallaecio) c04250fe2e lua 5.3.3
Packages that do not support latest Lua have been moved to the CCR. If requested,
we could package lua52 and lua51 in the official repoitories to support popular
packages that have not yet caught up with latest Lua.
2016-09-21 23:49:54 +02:00

31 lines
904 B
Bash

# Contributions from Arch: https://projects.archlinux.org/svntogit/community.git/tree/trunk?h=packages/freedroidrpg
pkgname=freedroid
_pkgname1=freedroidrpg
pkgver=0.16.1
pkgrel=2
pkgdesc="A mature science-fiction role-playing game set in the future."
arch=('x86_64')
url="http://freedroid.sourceforge.net"
screenshot='http://www.freedroid.org/typo3temp/pics/469c9a5549.jpg'
license=(GPL2)
depends=('lua' 'sdl_gfx' 'sdl_mixer' 'sdl_image' 'libogg' 'libvorbis' 'libgl' 'mesa' 'glu')
makedepends=('python2' 'espeak')
optdepends=('python2' 'espeak')
categories=('games')
replaces=($_pkgname1)
source=(ftp://ftp.osuosl.org/pub/${pkgname}/${pkgname}RPG-${pkgver:0:4}/freedroidRPG-${pkgver}.tar.gz)
md5sums=('ba19730c0139df810602ea9252d47120')
build() {
cd $srcdir/$_pkgname1-$pkgver
./configure \
--prefix=/usr
make
}
package() {
cd $srcdir/$_pkgname1-$pkgver
make DESTDIR=$pkgdir/ install
}