mirror of
https://gitdl.cn/https://github.com/chakralinux/desktop.git
synced 2025-01-23 18:14:51 +08:00
40 lines
928 B
Bash
40 lines
928 B
Bash
pkgname=freeorion
|
|
pkgver=0.4.8
|
|
pkgrel=1
|
|
pkgdesc="turn-based space empire and galactic conquest (4X) computer game"
|
|
arch=('x86_64')
|
|
url="https://github.com/freeorion/freeorion/"
|
|
license=('GPL2')
|
|
depends=('boost-libs' 'python2' 'sdl2' 'libvorbis' 'glew' 'libtiff' 'libjpeg-turbo' 'openal' 'hicolor-icon-theme' 'freetype2')
|
|
makedepends=('boost' 'cmake' 'doxygen')
|
|
conflicts=('gigi')
|
|
replaces=('gigi')
|
|
source=("$pkgname-$pkgver::https://github.com/freeorion/freeorion/archive/v$pkgver.tar.gz")
|
|
sha256sums=('1dac72c40bb9b881699423c98b14a9cd71b3f88cd2ec3433d5456cdd8dfa9621')
|
|
|
|
prepare() {
|
|
cd $srcdir/$pkgname-$pkgver
|
|
|
|
# patch -Np1 -i ../boost1.37.patch
|
|
|
|
mkdir -p build
|
|
}
|
|
|
|
build() {
|
|
cd $srcdir/$pkgname-$pkgver/build
|
|
|
|
cmake \
|
|
-DCMAKE_INSTALL_PREFIX=/usr \
|
|
-DCMAKE_INSTALL_LIBDIR=lib \
|
|
-DCMAKE_BUILD_TYPE=Release \
|
|
..
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd $srcdir/$pkgname-$pkgver/build
|
|
|
|
make DESTDIR=$pkgdir install
|
|
}
|