mirror of
https://gitdl.cn/https://github.com/chakralinux/desktop.git
synced 2025-01-23 18:14:51 +08:00
0af05b343a
renamed checksums to kdeapps.sums added for all packages the pgp signature for new/removed packages check: https://community.kde.org/Applications/16.12_Release_Notes#Tarballs_that_we_have_split
54 lines
1.7 KiB
Bash
54 lines
1.7 KiB
Bash
# Maintainer: george2 <rpubaddr0 {at} gmail [dot] com>
|
|
# Contributors: Jelle van der Waa <jelle@vdwaa.nl>
|
|
# Arch Haskell Team <arch-haskell@haskell.org>
|
|
|
|
## NOTE: when you update Haskell packages you'll have to update the entire stack to not break it ##
|
|
|
|
_hkgname=network-uri
|
|
pkgname=haskell-network-uri
|
|
pkgver=2.6.1.0
|
|
pkgrel=1
|
|
pkgdesc="A library for URI manipulation"
|
|
url="http://hackage.haskell.org/package/${_hkgname}"
|
|
license=('custom:BSD3')
|
|
arch=('i686' 'x86_64')
|
|
options=('staticlibs')
|
|
depends=('ghc' 'haskell-parsec<3.2')
|
|
source=("http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
|
|
install=${pkgname}.install
|
|
md5sums=('c6ed1e8314a9b1674a3d118d9019a229')
|
|
|
|
build() {
|
|
cd "${_hkgname}-${pkgver}"
|
|
|
|
runhaskell Setup configure -O -p \
|
|
--enable-split-objs \
|
|
--enable-shared \
|
|
--prefix=/usr \
|
|
--docdir="/usr/share/doc/${pkgname}" \
|
|
--libsubdir=\$compiler/site-local/\$pkgid
|
|
|
|
runhaskell Setup build
|
|
|
|
runhaskell Setup haddock
|
|
|
|
runhaskell Setup register --gen-script
|
|
runhaskell Setup unregister --gen-script
|
|
sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
|
|
}
|
|
|
|
package() {
|
|
cd "${_hkgname}-${pkgver}"
|
|
|
|
install -D -m744 register.sh "${pkgdir}/usr/share/haskell/${pkgname}/register.sh"
|
|
install -m744 unregister.sh "${pkgdir}/usr/share/haskell/${pkgname}/unregister.sh"
|
|
|
|
install -d -m755 "${pkgdir}/usr/share/doc/ghc/html/libraries"
|
|
ln -s "/usr/share/doc/${pkgname}/html" "${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}"
|
|
|
|
runhaskell Setup copy --destdir="${pkgdir}"
|
|
|
|
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
|
|
rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
|
|
}
|