mirror of
https://gitdl.cn/https://github.com/chakralinux/desktop.git
synced 2025-01-23 18:14:51 +08:00
31 lines
788 B
Bash
31 lines
788 B
Bash
pkgname=hidapi
|
|
pkgver=0.8.0rc1
|
|
_hidapiver=0.8.0-rc1
|
|
pkgrel=1
|
|
pkgdesc="Simple library for communicating with USB and Bluetooth HID devices"
|
|
arch=('x86_64')
|
|
url="http://www.signal11.us/oss/hidapi/"
|
|
license=('GPL3' 'BSD' 'custom')
|
|
depends=('libusb')
|
|
source=("https://github.com/signal11/hidapi/archive/hidapi-${_hidapiver}.tar.gz")
|
|
md5sums=('069f9dd746edc37b6b6d0e3656f47199')
|
|
|
|
build() {
|
|
cd "${srcdir}/hidapi-hidapi-${_hidapiver}"
|
|
|
|
./bootstrap
|
|
./configure --prefix=/usr
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd "${srcdir}/hidapi-hidapi-${_hidapiver}"
|
|
|
|
make DESTDIR="${pkgdir}/" install
|
|
|
|
mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
|
|
rm -f "${pkgdir}/usr/share/doc/hidapi/"LICENSE*
|
|
install -m644 LICENSE.txt LICENSE-bsd.txt LICENSE-orig.txt "${pkgdir}/usr/share/licenses/${pkgname}/"
|
|
}
|
|
|