mirror of
https://gitdl.cn/https://github.com/chakralinux/desktop.git
synced 2025-01-23 18:14:51 +08:00
48 lines
1.3 KiB
Bash
48 lines
1.3 KiB
Bash
pkgname=keepassxc
|
|
pkgver=2.3.4
|
|
pkgrel=1
|
|
pkgdesc="KeePassXC is a cross platform community driven port of the windows application Keepass Password Safe"
|
|
arch=('x86_64')
|
|
url="https://keepassxc.org/"
|
|
license=('GPL2')
|
|
screenshot="http://i1-win.softpedia-static.com/screenshots/KeePassXC_1.png"
|
|
depends=('hicolor-icon-theme' 'libxtst' 'qt5-x11extras' 'libgcrypt' 'curl' 'libsodium>=1.0.12' 'yubikey-personalization' 'argon2')
|
|
makedepends=('cmake' 'qt5-tools')
|
|
provides=('keepassx' 'keepassx-reboot')
|
|
conflicts=('keepassx-reboot')
|
|
replaces=('keepassx-reboot')
|
|
source=("https://github.com/keepassxreboot/$pkgname/releases/download/$pkgver/$pkgname-$pkgver-src.tar.xz")
|
|
sha256sums=('0c24a78895185b9b6b098f08a15b332c600f80aa570d608940fcc2a38e02780a')
|
|
|
|
prepare() {
|
|
cd $pkgname-$pkgver
|
|
mkdir -p build
|
|
}
|
|
|
|
build() {
|
|
cd $pkgname-$pkgver/build
|
|
cmake -DCMAKE_INSTALL_PREFIX=/usr \
|
|
-DCMAKE_INSTALL_BINDIR=/usr/bin \
|
|
-DCMAKE_INSTALL_LIBDIR=/usr/lib \
|
|
-DCMAKE_VERBOSE_MAKEFILE=OFF \
|
|
-DWITH_GUI_TESTS=OFF \
|
|
-DWITH_XC_AUTOTYPE=ON \
|
|
-DWITH_XC_NETWORKING=ON \
|
|
-DWITH_XC_HTTP=ON \
|
|
-DWITH_XC_BROWSER=ON \
|
|
-DWITH_XC_YUBIKEY=ON \
|
|
-DCMAKE_BUILD_TYPE=Release ..
|
|
make
|
|
}
|
|
|
|
#check() {
|
|
# cd $pkgname-$pkgver/build
|
|
# make test
|
|
#}
|
|
|
|
package() {
|
|
cd $pkgname-$pkgver/build
|
|
make DESTDIR=$pkgdir install
|
|
}
|
|
|