mirror of
https://gitdl.cn/https://github.com/chakralinux/desktop.git
synced 2025-01-23 18:14:51 +08:00
33 lines
849 B
Bash
33 lines
849 B
Bash
# Contributors from Arch: https://www.archlinux.org/packages/extra/x86_64/libaccounts-qt4/
|
|
|
|
pkgname='libaccounts-qt'
|
|
pkgver=1.14
|
|
_commit=a34ca4b
|
|
pkgrel=1
|
|
pkgdesc="Qt5-based client library for accessing the online accounts database"
|
|
arch=('x86_64')
|
|
url="http://code.google.com/p/accounts-sso/"
|
|
license=('LGPL')
|
|
depends=('qt5-base' 'libaccounts-glib')
|
|
makedepends=('doxygen')
|
|
replaces=('libaccounts-qt5')
|
|
options=('!docs' '!emptydirs')
|
|
source=("https://gitlab.com/accounts-sso/libaccounts-qt/repository/archive.tar.bz2?ref=$_commit")
|
|
sha1sums=('4cc4dd77888bbc31cb22e97523bfd749a4d01b78')
|
|
|
|
prepare() {
|
|
cd $pkgname-*
|
|
sed -i 's|SUBDIRS += Accounts tests|SUBDIRS += Accounts|' accounts-qt.pro
|
|
}
|
|
|
|
build() {
|
|
cd ${srcdir}/$pkgname-*
|
|
qmake-qt5 PREFIX=/usr LIBDIR=/usr/lib
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd $pkgbase-*
|
|
make INSTALL_ROOT="$pkgdir" install
|
|
}
|