mirror of
https://gitdl.cn/https://github.com/chakralinux/desktop.git
synced 2025-01-23 18:14:51 +08:00
29 lines
539 B
Bash
29 lines
539 B
Bash
|
|
pkgname=libnftnl
|
|
pkgver=1.1.2
|
|
pkgrel=1
|
|
pkgdesc='Netfilter library providing interface to the nf_tables subsystem'
|
|
arch=('x86_64')
|
|
url='https://netfilter.org/projects/libnftnl/'
|
|
license=('GPL2')
|
|
depends=('libmnl')
|
|
source=("https://netfilter.org/projects/libnftnl/files/libnftnl-$pkgver.tar.bz2")
|
|
sha1sums=('c0f880588fabaa845a88fb5a2bdad0dea7481857')
|
|
|
|
build() {
|
|
cd $pkgname-$pkgver
|
|
./configure --prefix=/usr
|
|
make
|
|
}
|
|
|
|
check() {
|
|
cd $pkgname-$pkgver
|
|
make check
|
|
}
|
|
|
|
package() {
|
|
cd $pkgname-$pkgver
|
|
make DESTDIR="$pkgdir" install
|
|
}
|
|
|