desktop/libtorrent-rasterbar/PKGBUILD

58 lines
1.5 KiB
Bash

pkgname=libtorrent-rasterbar
pkgver=1.1.11
_pkgver=${pkgver//./_}
pkgrel=1
pkgdesc="A C++ library that aims to be a good alternative to all the other bittorrent implementations around"
url="https://libtorrent.org/"
arch=('x86_64')
license=('BSD')
depends=('boost-libs' 'python2' 'python3' 'geoip' 'websocketpp')
makedepends=('boost' 'cmake')
options=('!emptydirs')
source=(https://github.com/arvidn/libtorrent/archive/libtorrent_${_pkgver}/$pkgname-$pkgver.tar.gz)
sha256sums=('d98ea107513537771ce661d17ccc16148cda1294c2d42ff4efe314482e0de441')
prepare() {
mkdir py2 py3
cd libtorrent-libtorrent_${_pkgver}
# Avoid depending on newer processors
sed -i 's/-msse4.2//' configure.ac
./autotool.sh
}
_build() (
cd py$1
# FS#50745
_boost="boost_python"
if [ $1 -eq 3 ]; then _boost="boost_python3"; fi
# https://github.com/qbittorrent/qBittorrent/issues/5265#issuecomment-220007436
CXXFLAGS="$CXXFLAGS -std=c++11" \
PYTHON=/usr/bin/python$1 \
../libtorrent-libtorrent_${_pkgver}/configure \
--prefix=/usr \
--enable-python-binding \
--enable-examples \
--disable-static \
--with-libiconv \
--with-boost-python=$_boost
)
build() {
_build 2
_build 3
}
package() {
make -C py2 DESTDIR="$pkgdir" install
make -C py3 DESTDIR="$pkgdir" install
install -Dm644 libtorrent-libtorrent_${_pkgver}/COPYING \
"$pkgdir/usr/share/licenses/$pkgname/LICENSE"
# Remove most example binaries
rm "$pkgdir"/usr/bin/{*_test,*_tester,simple_client,stats_counters}
}