mirror of
https://gitdl.cn/https://github.com/chakralinux/desktop.git
synced 2025-01-23 18:14:51 +08:00
23 lines
672 B
Bash
23 lines
672 B
Bash
pkgname=mxml
|
|
pkgver=2.10
|
|
pkgrel=1
|
|
pkgdesc="Mini-XML is a small XML parsing library: read/write XML and XML-like data files in your application without requiring large non-standard libraries."
|
|
arch=('x86_64')
|
|
url="http://www.minixml.org/"
|
|
license=('LGPL')
|
|
source=("$pkgname-$pkgver.tar.gz::https://github.com/michaelrsweet/mxml/archive/release-$pkgver.tar.gz")
|
|
sha256sums=('bbc8cc3ed5afb5482f531949f5de86b6d24ea5d85bce7b35c49917c300159da9')
|
|
|
|
build() {
|
|
cd "$srcdir/$pkgname-release-$pkgver"
|
|
./configure --prefix=/usr --enable-shared
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd "$srcdir/$pkgname-release-$pkgver"
|
|
make DSTROOT="$pkgdir" install
|
|
chmod -x "$pkgdir/usr/lib/libmxml.a"
|
|
|
|
}
|