mirror of
https://gitdl.cn/https://github.com/chakralinux/desktop.git
synced 2025-01-23 18:14:51 +08:00
39 lines
917 B
Bash
39 lines
917 B
Bash
pkgname=nmap
|
|
pkgver=7.70
|
|
pkgrel=1
|
|
pkgdesc="A network exploration tool and security/port scanner"
|
|
arch=('x86_64')
|
|
url="http://nmap.org"
|
|
license=('custom:GPL')
|
|
depends=('pcre' 'openssl' 'libpcap>=1.0.0' 'lua')
|
|
# pygtk is needed for zenmap
|
|
makedepends=('python2')
|
|
optdepends=('pygtk: gui for nmap - zenmap')
|
|
options=('!makeflags')
|
|
source=(http://nmap.org/dist/${pkgname}-${pkgver}.tar.bz2)
|
|
sha256sums=('847b068955f792f4cc247593aca6dc3dc4aae12976169873247488de147a6e18')
|
|
|
|
build() {
|
|
cd "${srcdir}/${pkgname}-${pkgver}"
|
|
|
|
export PYTHON=python2
|
|
./configure \
|
|
--prefix=/usr \
|
|
--libexecdir=/usr/lib \
|
|
--mandir=/usr/share/man
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd "${srcdir}/${pkgname}-${pkgver}"
|
|
|
|
make DESTDIR="${pkgdir}" install
|
|
|
|
# remove zenmap uninstall script
|
|
rm "${pkgdir}/usr/bin/uninstall_zenmap"
|
|
|
|
# install custom GPL2 license
|
|
install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
|
|
}
|