mirror of
https://gitdl.cn/https://github.com/chakralinux/desktop.git
synced 2025-01-23 18:14:51 +08:00
33 lines
805 B
Bash
33 lines
805 B
Bash
pkgname=peruse
|
|
pkgver=1.2
|
|
pkgrel=2
|
|
pkgdesc="A comic book reader. It gets out of your way and let you read your comics, comfortably"
|
|
license=('GPL')
|
|
arch=('x86_64')
|
|
url="https://peruse.kde.org/"
|
|
depends=('qt5-base' 'karchive' 'baloo' 'ki18n' 'kdeclarative' 'kconfig' 'kfilemetadata' 'kiconthemes' 'kio' 'kirigami')
|
|
makedepends=('extra-cmake-modules')
|
|
categories=('office')
|
|
options=('debug')
|
|
source=("http://download.kde.org/stable/${pkgname}/${pkgname}-${pkgver}.tar.xz")
|
|
sha1sums=('1f91d84086e71dcd6e2a853aac04dfd50bc7fc9a')
|
|
|
|
prepare() {
|
|
mkdir -p build
|
|
}
|
|
|
|
build() {
|
|
cd build
|
|
cmake ../$pkgname \
|
|
-DCMAKE_BUILD_TYPE=Release \
|
|
-DCMAKE_INSTALL_PREFIX=/usr \
|
|
-DKDE_INSTALL_LIBDIR=lib \
|
|
-DKDE_INSTALL_USE_QT_SYS_PATHS=ON
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd build
|
|
make DESTDIR="$pkgdir" install
|
|
}
|