desktop/plasma5-applets-bumblebee-indicator/PKGBUILD
2017-11-05 21:33:25 +01:00

38 lines
1.0 KiB
Bash

pkgname=plasma5-applets-bumblebee-indicator
_name=bumblebee-indicator
pkgver=0.4
pkgrel=1
pkgdesc="Indicates the Nvidia card's on or off status on the Optimus systems, when bumblebee is used."
arch=('x86_64')
url="https://github.com/bxabi/bumblebee-indicator"
license=('GPL')
group=('plasma5-applets')
depends=('plasma-workspace' 'qt5-graphicaleffects')
makedepends=('extra-cmake-modules')
_commit="ee45911bd50115cf7c96cc36177d5f8bca823f33"
source=("https://github.com/bxabi/bumblebee-indicator/archive/${_commit}.zip")
sha256sums=('5cd893f0bca21f2f08c5126d6866527e4034d231f0c512384180ba58f8dc7d15')
prepare() {
cd $_name-${_commit}
mkdir -p build
}
build() {
cd "$_name-${_commit}/build"
cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
-DLIB_INSTALL_DIR=lib \
-DKDE_INSTALL_USE_QT_SYS_PATHS=ON
}
package() {
cd "$_name-${_commit}/build"
make install DESTDIR="${pkgdir}"
mv $pkgdir/usr/share/plasma/plasmoids/bumblebee-kde5-plasmoid \
$pkgdir/usr/share/plasma/plasmoids/com.bxabi.bumblebee-indicator
}