mirror of
https://gitdl.cn/https://github.com/chakralinux/desktop.git
synced 2025-01-23 18:14:51 +08:00
64 lines
1.8 KiB
Bash
64 lines
1.8 KiB
Bash
_name=scipy
|
|
pkgname=('python3-scipy' 'python2-scipy')
|
|
pkgver=1.1.0
|
|
pkgrel=1
|
|
pkgdesc="SciPy is open-source software for mathematics, science, and engineering."
|
|
arch=('x86_64')
|
|
url="https://www.scipy.org/"
|
|
license=('BSD')
|
|
makedepends=('gcc-fortran' 'python3-numpy' 'python2-numpy' 'python3-setuptools' 'python2-setuptools')
|
|
source=("https://pypi.python.org/packages/source/${_name:0:1}/${_name}/${_name}-${pkgver}.tar.gz")
|
|
sha256sums=('878352408424dffaa695ffedf2f9f92844e116686923ed9aa8626fc30d32cfd1')
|
|
|
|
build() {
|
|
export LDFLAGS="-Wall -shared"
|
|
|
|
# 2 builds
|
|
cp -r scipy-${pkgver} scipy-${pkgver}-py2
|
|
|
|
# build for python3
|
|
cd scipy-${pkgver}
|
|
python3 setup.py config_fc --fcompiler=gnu95 build
|
|
|
|
# build for python2
|
|
cd ../scipy-${pkgver}-py2
|
|
|
|
for file in $(find . -name '*.py' -print); do
|
|
sed -i 's_^#!.*/usr/bin/python_#!/usr/bin/python2_' $file
|
|
sed -i 's_^#!.*/usr/bin/env.*python_#!/usr/bin/env python2_' $file
|
|
done
|
|
|
|
python2 setup.py config_fc --fcompiler=gnu95 build
|
|
}
|
|
|
|
package_python3-scipy() {
|
|
depends=('python3-numpy')
|
|
provides=('python3-scipy' 'scipy')
|
|
optdepends=('python3-pillow: for image saving module')
|
|
|
|
cd scipy-${pkgver}
|
|
export LDFLAGS="-Wall -shared"
|
|
|
|
python3 setup.py config_fc --fcompiler=gnu95 install \
|
|
--prefix=/usr --root=${pkgdir} --optimize=1
|
|
|
|
install -Dm644 LICENSE.txt \
|
|
"${pkgdir}/usr/share/licenses/python3-scipy/LICENSE"
|
|
}
|
|
|
|
package_python2-scipy() {
|
|
depends=('python2-numpy')
|
|
optdepends=('python2-pillow: for image saving module')
|
|
conflicts=('python3-scipy<0.9.0')
|
|
|
|
cd scipy-${pkgver}-py2
|
|
export LDFLAGS="-Wall -shared"
|
|
|
|
python2 setup.py config_fc --fcompiler=gnu95 install \
|
|
--prefix=/usr --root=${pkgdir} --optimize=1
|
|
|
|
install -Dm644 LICENSE.txt \
|
|
"${pkgdir}/usr/share/licenses/python2-scipy/LICENSE"
|
|
}
|
|
|